skip to Main Content

How to Remove Minim Config with RemoteWinBox Fleet Commander

You just got set up with your RemoteWinBox Admiral, things are looking great, and the online/offline graph is green! The only thing that’s left is to remove the old configuration to off-board the routers from Minim. It could be a tedious task doing that router per router. Luckily, Fleet Commander comes to the rescue! You can paste the script into your Fleet Commander, save it, and re-run it however many times you may need.

You can find the script below:

/system scheduler remove [ find where comment~"Minim" ];
/system scheduler remove [find where comment~"reboot"];
/system script remove [find where comment~"Minim"];
/system script job remove [find where type="api-login"];
/system script environment remove [find where name~"minim"];
/system script environment remove [find where name~"dhcpOptions"];
/user remove [find where comment~"Minim"];
/user remove [find where comment="ISP User"];
/user remove [find where comment="ISP_USER"];
/user remove [find where comment="API_USER"];
/user remove [find where comment="SPEEDTEST_USER"];
/ip route remove [ find where comment="WINBOX_ACCESS" ];
/ip route remove [ find where comment~"Minim" ];
/ip route remove [ find where comment~"Aerez" ];
/ip route remove [ find where comment="custom route" ];
/ip route remove [ find where dst-address="10.0.0.176/32" ];
/ip route remove [ find where dst-address="10.0.0.0/24" gateway="10.0.128.1" ];
/queue simple remove [ find where comment~"Minim" ];
/interface sstp-client remove [ find where name~"Minim" ];
/interface l2tp-client remove [ find where name~"Minim" ];
/interface wireless set [ find where comment~"Minim" ] comment="";
/ppp profile remove [ find where name="Minim" ];
/ip service set api address="10.0.0.0/8,172.16.0.0/12,192.168.0.0/16" disabled=no;
/ip service set ssh address="10.0.0.0/8,172.16.0.0/12,192.168.0.0/16" disabled=no;
/ip service set winbox address="10.0.0.0/8,172.16.0.0/12,192.168.0.0/16" disabled=no;
/ip firewall address-list remove [find where list~"aerez"];
/ip firewall address-list remove [find where list~"mcp"];
/ip firewall address-list remove [find where address~"tikvpn"];
/ip firewall address-list remove [find where comment~"Minim"];
/ip traffic-flow set enabled=no;
/ip traffic-flow target remove [ find where dst-address=10.0.6.114 ];
/tool sniffer stop;
/tool sniffer set streaming-enabled=no;
/tool traffic-generator packet-template remove [ /tool traffic-generator packet-template find ];
/tool traffic-generator stream remove [ /tool traffic-generator stream find ];
/tool traffic-generator port remove [ /tool traffic-generator port find ];
/ip firewall nat remove [ find where comment~"Minim" ];
/ip firewall nat remove [find where dst-address="10.0.6.114"];
/ip firewall nat remove [find where comment~"Aerez"];
/ip firewall filter remove [find where comment~"Aerez"];
/ip firewall filter remove [find where comment="Local access"];
/ip firewall filter remove [find where comment="trust_vpn"];
/ip firewall filter remove [find where comment="Never gets paused"];
/ip firewall filter remove [find where comment~"Minim"];
/ip firewall filter set disabled=no [find where action="fasttrack-connection"];
/ip dhcp-server set [ find where lease-script~":if" ] lease-script="";

Even though this script has been run on thousands of MikroTiks, we recommend running the script on one router to start, then a handful, and then in larger batches (or all, depending on your deployment size), checking the routers in between the runs to make sure things look good.

If you have any questions, or need help getting started, feel free to reach out to support@remotewinbox.com and we’ll be happy to help!

Back To Top